WordPress 3.5.1

Esta mañana, el equipo de desarrollo del conocido CMS nos ha sorprendido a todos los que utilizamos WordPress al leer en la parte superior de la pantalla el típico mensaje: ¡WordPress 3.5.1 está disponible! Por favor, actualiza ahora.

La actualización fue lanzada ayer 24 de enero, y la marcan como una actualización de mantenimiento y seguridad. Se han arreglado 37 bugs, entre los cuales están:

  • Editor: Corrige la desaparición o modificación de elementos HTML en casos raros.
  • Media: Corrige varios problemas menores de funcionamiento y compatibilidad del nuevo media manager.
  • Networks: Sugiere reglas de reescritura apropiadas cuando se crea una nueva red de sitios (Multisitio).
  • Previene que en las entradas programadas se pierda cierto contenido HTML al ser publicadas, como videos embebidos.
  • Corrige ciertas desconfiguraciones que han causado algunos JavaScript en el area de administración.
  • Suprime ciertos mensajes “Warning” que salen cuando un plugin hace un mal uso de la base de datos o la API de usuario.

Adicionalmente, WordPress 3.5.1 arregla varios problemas de seguridad:

  • Server-side request forgery (SSRF) y escaneo remoto de puertos via pingbacks. Arreglado por el WordPress security team.
  • Cross-site scripting (XSS) a través de shortcodes y contenido de entradas. Descubierto por Jon Cave del WordPress security team.
  • Cross-site scripting (XSS) en la libreria externa Plupload. Plupload 1.5.5 se ha lanzado para documentar este problema.

Tienes una lista completa de los bugs que WordPress 3.5.1 arregla en esta página (en inglés).

“¡WordPress 3.5.1 está disponible! Por favor, actualiza ahora.”

¿Te ha gustado el artículo?
Sé el primero en calificar esta publicación.
1 estrella2 estrellas3 estrellas4 estrellas5 estrellas
Loading...
Artículo escrito por

¡Exprésate! Dejanos tu comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *



Aún no hay comentarios en esta entrada. ¿Te animas?